<rt id="bn8ez"></rt>
<label id="bn8ez"></label>

  • <span id="bn8ez"></span>

    <label id="bn8ez"><meter id="bn8ez"></meter></label>

    posts - 36,  comments - 3,  trackbacks - 0
    Give you the width and height of the rectangle,darw it.
    Input
    Input contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.

    Output
    For each case,you should draw a rectangle with the width and height giving in the input.
    after each case, you should a blank line.

    Sample Input
    3 2
    Sample Output
    +---+ | | | |

    +---+



    #include<stdio.h>
    int main()
    {
     char a[1000];
     char b[80][10000];
     int n,m;
     while((scanf("%d%d",&n,&m))!=EOF&&m<75)
     {
      getchar();
      a[0]=a[n+1]='+';
      int i,j;
      for(i=1;i<=n;i++)
       a[i]='-';
      for(j=1;j<m+1;j++)
      {
       for(i=0;i<=n+1;i++)
       {  if(i==0||i==n+1)
         b[j][i]='|';
         else
         b[j][i]=' ';
       }

      }


      for(i=0;i<=n+1;i++)
       printf("%c",a[i]);
       printf("\n");
      for(i=1;i<=m;i++)
      {

       for(j=0;j<=n+1;j++)
       {
        printf("%c",b[i][j]);
       }
       printf("\n");
      }

      for(i=0;i<=n+1;i++)
       printf("%c",a[i]);
      printf("\n\n");
     }
    }

    posted on 2012-07-13 16:51 天YU地___PS,代碼人生 閱讀(169) 評論(0)  編輯  收藏

    只有注冊用戶登錄后才能發表評論。


    網站導航:
     
    <2012年7月>
    24252627282930
    1234567
    891011121314
    15161718192021
    22232425262728
    2930311234

     一定要好好學習,天天向上!

    常用鏈接

    留言簿

    隨筆分類(8)

    隨筆檔案(35)

    文章分類

    文章檔案(1)

    搜索

    •  

    最新評論

    閱讀排行榜

    評論排行榜

    主站蜘蛛池模板: 久久精品国产亚洲AV大全| 亚洲欧洲无码AV不卡在线| 狼群影院在线观看免费观看直播| 亚洲女人18毛片水真多| 国产男女猛烈无遮挡免费视频网站| 中文字幕免费人成乱码中国| 亚洲精品一卡2卡3卡三卡四卡| 吃奶摸下高潮60分钟免费视频| 日韩精品无码一区二区三区免费| 亚洲欧洲日产国码久在线| 亚洲人成人无码网www电影首页| 欧美最猛性xxxxx免费| 久久免费99精品国产自在现线| 亚洲专区中文字幕| 在线亚洲97se亚洲综合在线| 国产精品久久免费| 两个人的视频www免费| 午夜亚洲WWW湿好爽| 亚洲日韩区在线电影| 亚洲毛片网址在线观看中文字幕| 色播精品免费小视频| 手机看片国产免费永久| 亚洲а∨精品天堂在线| 午夜亚洲国产理论秋霞| 亚洲成AV人在线观看网址| 成人无遮挡裸免费视频在线观看| a毛片在线免费观看| 羞羞漫画页面免费入口欢迎你| 激情综合亚洲色婷婷五月APP| 国产V亚洲V天堂A无码| 亚洲A∨午夜成人片精品网站| 日韩欧美一区二区三区免费观看| 国产无遮挡无码视频免费软件| 黄床大片30分钟免费看| 亚洲午夜在线播放| 亚洲网址在线观看| 亚洲AV无码专区国产乱码4SE| 精品国产日韩亚洲一区| 免费国产在线观看不卡| 日韩一级视频免费观看| 成人啪精品视频免费网站|